blob: 00b9eadfc600e8ab0453ac5fba369c18bab45692 [file] [log] [blame]
Adriana Kobylak8c6707f2021-08-06 17:35:36 +00001FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
Marri Devender Raocf233f12019-09-25 03:19:29 -05002SRC_URI += "file://plugins.d/guard"
3
4install_openpower_plugins() {
5 install -m 0755 ${WORKDIR}/plugins.d/guard ${D}${dreport_plugin_dir}
6}
7
8#Link in the plugins so dreport run them at the appropriate time
9python link_openpower_plugins() {
10 workdir = d.getVar('WORKDIR', True)
11 script = os.path.join(workdir, 'plugins.d', 'guard')
12 install_dreport_user_script(script, d)
13}
14
15DEBUG_COLLECTOR_INSTALL_POSTFUNCS ?= ""
Adriana Kobylak8c6707f2021-08-06 17:35:36 +000016DEBUG_COLLECTOR_INSTALL_POSTFUNCS:df-openpower ?= "install_openpower_plugins link_openpower_plugins"
Marri Devender Raocf233f12019-09-25 03:19:29 -050017
18do_install[postfuncs] += "${DEBUG_COLLECTOR_INSTALL_POSTFUNCS}"