blob: ce216b0164b7e12d504512d007218a5180500466 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001DESCRIPTION = "Python SQL toolkit and Object Relational Mapper that gives \
2application developers the full power and flexibility of SQL"
3HOMEPAGE = "http://www.sqlalchemy.org/"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=b707d50badb798e1d897f2c8f649382d"
6
7SRC_URI[sha256sum] = "c1bda93cbbe4aa2aa0aa8655c5aeda505cd219ff3e8da91d1d329e143e4aff69"
8
9PYPI_PACKAGE = "SQLAlchemy"
10inherit pypi setuptools3
11
12RDEPENDS:${PN} += " \
13 python3-asyncio \
14 python3-compression \
15 python3-json \
16 python3-logging \
17 python3-netclient \
18 python3-numbers \
19 python3-pickle \
20 python3-profile \
21 python3-threading \
22 python3-typing-extensions \
23"
24
25BBCLASSEXTEND = "native nativesdk"