blob: 070ed1904bb4814895b42a77a3673be09aefa0f7 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "The GIMP is the GNU Image Manipulation Program"
2HOMEPAGE = "http://www.gimp.org"
3SECTION = "x11/graphics"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=c678957b0c8e964aa6c70fd77641a71e"
6
7DEPENDS = " \
8 gdk-pixbuf-native \
9 intltool-native \
10 libxslt-native \
11 gegl-native \
12 dbus-glib \
13 gtk+ \
14 babl \
15 gegl \
16 libmypaint \
17 mypaint-brushes-1.0 \
18 gexiv2 \
19 jpeg \
20 libpng \
21 libexif \
22 tiff \
23 lcms \
24 poppler \
25 poppler-data \
26 jasper \
27 bzip2 \
28 libgudev \
29 libmng \
30 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxmu libxpm', '', d)} \
31"
32DEPENDS_append_libc-musl = " libexecinfo"
33
34inherit features_check gnomebase gtk-icon-cache gtk-doc mime-xdg
35
36REQUIRED_DISTRO_FEATURES = "x11"
37
38SHPV = "${@gnome_verdir("${PV}")}"
39
Andrew Geisslerac970dd2021-02-12 15:32:45 -060040SRC_URI = "https://download.gimp.org/pub/${BPN}/v${SHPV}/${BP}.tar.bz2 \
41 file://0001-configure.ac-fix-with-linux-input-handling-with-upco.patch \
42 "
Andrew Geisslerbbbd5f42020-10-30 15:42:48 -050043SRC_URI[sha256sum] = "2db84b57f3778d80b3466d7c21a21d22e315c7b062de2883cbaaeda9a0f618bb"
Andrew Geissler82c905d2020-04-13 13:39:40 -050044
45EXTRA_OECONF = "--disable-python \
46 --without-webkit \
47 --without-wmf"
48
49EXTRA_OECONF_append_libc-musl_mipsarch = " --disable-vector-icons"
50EXTRA_OECONF_append_toolchain-clang_arm = " --disable-vector-icons"
51
52do_configure_append() {
53 find ${B} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
54 find ${B} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
55}
56
57do_compile_prepend() {
58 # Let native babl/gegl find their plugins
59 export BABL_PATH=`find ${STAGING_LIBDIR_NATIVE} -maxdepth 1 -name 'babl-*'`
60 export GEGL_PATH=`find ${STAGING_LIBDIR_NATIVE} -maxdepth 1 -name 'gegl-*'`
61}
62
63FILES_${PN} += "${datadir}/metainfo"
64
65RDEPENDS_${PN} += "mypaint-brushes-1.0"