blob: 9d4c305fc76133a8cc84ea6bdf9d8ae558185bf9 [file] [log] [blame]
Andrew Geisslerac970dd2021-02-12 15:32:45 -06001DESCRIPTION = "library implementing Secure RTP (RFC 3711)"
2HOMEPAGE = "https://github.com/cisco/libsrtp"
3SECTION = "libs"
4
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=2909fcf6f09ffff8430463d91c08c4e1"
7
8S = "${WORKDIR}/git"
9SRCREV = "d02d21111e379c297e93a9033d7b653135f732ee"
10SRC_URI = "git://github.com/cisco/libsrtp.git"
11
12inherit autotools pkgconfig
13
14EXTRA_OEMAKE += "shared_library"
15
16do_configure_prepend() {
17 cp ${STAGING_DATADIR_NATIVE}/automake-*/ar-lib ${S}
18}
19
20ALLOW_EMPTY_${PN} = "1"