blob: a4b7f3432a2207fcaaa5f0de9e8eeca104fc7c40 [file] [log] [blame]
Andrew Geisslerac970dd2021-02-12 15:32:45 -06001SUMMARY = "cereal is a header-only C++11 serialization library"
2HOMEPAGE = "https://uscilab.github.io/cereal"
3LICENSE = "BSD & MIT & BSL-1.0"
4LIC_FILES_CHKSUM = "\
5 file://LICENSE;md5=e612690af2f575dfd02e2e91443cea23 \
6 file://include/cereal/external/rapidxml/license.txt;md5=d63ab70ba21ca0544b03284958324301 \
7 file://include/cereal/external/LICENSE;md5=b07578c9df99c0b8b45eb041efd4a645 \
8 file://include/cereal/external/rapidjson/LICENSE;md5=e7abb663111d4ac17cf00323698aff08 \
9 file://include/cereal/external/rapidjson/msinttypes/LICENSE;md5=dffce65b98c773976de2e338bd130f46 \
10"
11
12inherit cmake pkgconfig
13
14RDEPENDS_${PN}-dev = ""
15
16SRC_URI = " \
17 git://github.com/USCiLab/cereal.git;protocol=https \
18 file://0001-add-license-files-for-components-of-cereal.patch \
19"
20
21SRCREV = "02eace19a99ce3cd564ca4e379753d69af08c2c8"
22
23EXTRA_OECMAKE += "\
24 -DCEREAL_INSTALL=TRUE \
25 -DJUST_INSTALL_CEREAL=TRUE \
26"
27
28S = "${WORKDIR}/git"
29
30PROVIDES += "${PN}-dev"
31
32FILES_${PN}-dev = " \
33 ${includedir} \
34 ${libdir} \
35 ${datadir}/cmake \
36"