blob: 1b42590f428904024d5610bd529853b78108cb9a [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Linux tool to dump x86 CPUID information about the CPU(s)"
2DESCRIPTION = "cpuid dumps detailed information about the CPU(s) gathered \
3from the CPUID instruction, and also determines the exact model of CPU(s). \
4It supports Intel, AMD, and VIA CPUs, as well as older Transmeta, Cyrix, \
5UMC, NexGen, Rise, and SiS CPUs"
Andrew Geisslerac970dd2021-02-12 15:32:45 -06006HOMEPAGE="http://www.etallen.com/cpuid.html"
Andrew Geissler82c905d2020-04-13 13:39:40 -05007LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
9
10SRC_URI = "http://www.etallen.com/${BPN}/${BP}.src.tar.gz \
11 "
Andrew Geisslerac970dd2021-02-12 15:32:45 -060012SRC_URI[sha256sum] = "13c53f16408341d11ed489b352f218ec4dbb5bedb796a9d059e924770a9c56a6"
Andrew Geissler82c905d2020-04-13 13:39:40 -050013
14COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
15
16inherit perlnative
17
18# The install rule from the Makefile has hardcoded paths, so we duplicate
19# the actions to accommodate different paths.
20do_install () {
21 install -D -m 0755 ${B}/cpuid ${D}/${bindir}/cpuid
22 install -D -m 0444 ${B}/cpuid.man.gz ${D}/${mandir}
23}