blob: e5ad069d3cfd705ac75fd819ac5c3da3748687c1 [file] [log] [blame]
Andrew Geisslerc87764f2020-06-27 00:16:32 -05001SUMMARY = "Library for building powerful interactive command lines in Python"
2HOMEPAGE = "https://python-prompt-toolkit.readthedocs.io/"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b2cde7da89f0c1f3e49bf968d00d554f"
5
Andrew Geisslerac970dd2021-02-12 15:32:45 -06006SRC_URI[sha256sum] = "7e966747c18ececaec785699626b771c1ba8344c8d31759a1915d6b12fad6525"
Andrew Geisslerc87764f2020-06-27 00:16:32 -05007
8inherit pypi setuptools3
9
10PYPI_PACKAGE = "prompt_toolkit"
11
12RDEPENDS_${PN} += " \
13 ${PYTHON_PN}-core \
14 ${PYTHON_PN}-six \
15 ${PYTHON_PN}-terminal \
16 ${PYTHON_PN}-threading \
17 ${PYTHON_PN}-wcwidth \
18 ${PYTHON_PN}-datetime \
19 ${PYTHON_PN}-shell \
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050020 ${PYTHON_PN}-image \
Andrew Geisslerc87764f2020-06-27 00:16:32 -050021"
22
23BBCLASSEXTEND = "native nativesdk"