blob: e363729fd843ead7060422ff1d15e5d1167fcfdd [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001DESCRIPTION = "Python API for MISP"
2HOMEPAGE = "https://github.com/MISP/PyMISP"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=a3639cf5780f71b125d3e9d1dc127c20"
5
Andrew Geisslereef63862021-01-29 15:58:13 -06006SRC_URI = "git://github.com/MISP/PyMISP.git;protocol=https;branch=main"
Andrew Geisslerac970dd2021-02-12 15:32:45 -06007SRCREV = "f675e2096182532bb5870e4f773476b2d8065986"
Andrew Geisslereef63862021-01-29 15:58:13 -06008S = "${WORKDIR}/git"
Andrew Geissler82c905d2020-04-13 13:39:40 -05009
Andrew Geisslereef63862021-01-29 15:58:13 -060010inherit setuptools3
Andrew Geissler82c905d2020-04-13 13:39:40 -050011
12RDEPENDS_${PN} += " \
13 ${PYTHON_PN}-dateutil \
14 ${PYTHON_PN}-json \
15 ${PYTHON_PN}-jsonschema \
16 ${PYTHON_PN}-requests \
17 ${PYTHON_PN}-six \
18"
19
20# Fixes: python3-pymisp requires /bin/bash, but no
21# providers found in RDEPENDS_python3-pymisp? [file-rdep
22RDEPENDS_${PN} += "bash"