blob: fd7341953687b9b79175462841edf76ce1906a77 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Python WBEM Client and Provider Interface"
2DESCRIPTION = "\
3A Python library for making CIM (Common Information Model) operations over \
4HTTP using the WBEM CIM-XML protocol. It is based on the idea that a good \
5WBEM client should be easy to use and not necessarily require a large amount \
6of programming knowledge. It is suitable for a large range of tasks from \
7simply poking around to writing web and GUI applications. \
8\
9WBEM, or Web Based Enterprise Management is a manageability protocol, like \
10SNMP, standardised by the Distributed Management Task Force (DMTF) available \
11at http://www.dmtf.org/standards/wbem. \
12\
13It also provides a Python provider interface, and is the fastest and easiest \
14way to write providers on the planet."
15HOMEPAGE = "http://pywbem.github.io"
16LICENSE = "LGPLv2.1"
Brad Bishope42b3e32020-01-15 22:08:42 -050017LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fbc093901857fcd118f065f900982c24"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018
Andrew Geisslerac970dd2021-02-12 15:32:45 -060019SRC_URI[sha256sum] = "2abb6443f4debae56af7abefadb9fa5b8af9b53fc9bcf67f6c01a78db1064300"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080020
Andrew Geisslerd221e032020-07-10 16:13:21 -050021inherit pypi setuptools3 update-alternatives
Brad Bishope42b3e32020-01-15 22:08:42 -050022
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080023DEPENDS += " \
24 ${PYTHON_PN}-ply-native \
25 ${PYTHON_PN}-pyyaml-native \
26 ${PYTHON_PN}-six-native \
27"
28
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080029RDEPENDS_${PN}_class-target += "\
30 ${PYTHON_PN}-datetime \
31 ${PYTHON_PN}-io \
32 ${PYTHON_PN}-netclient \
33 ${PYTHON_PN}-ply \
34 ${PYTHON_PN}-pyyaml \
35 ${PYTHON_PN}-six \
36 ${PYTHON_PN}-stringold \
37 ${PYTHON_PN}-threading \
38 ${PYTHON_PN}-unixadmin \
39 ${PYTHON_PN}-xml \
40"
41
Andrew Geisslerd688a012020-09-18 13:36:00 -050042ALTERNATIVE_${PN} = "mof_compiler"
Andrew Geisslerd221e032020-07-10 16:13:21 -050043ALTERNATIVE_TARGET[mof_compiler] = "${bindir}/mof_compiler"
Andrew Geisslerd221e032020-07-10 16:13:21 -050044
45ALTERNATIVE_PRIORITY = "60"
46
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080047BBCLASSEXTEND = "native"