blob: 6bd46b1017dcbd6d10462c3609ecb06d98b34649 [file] [log] [blame]
Andrew Geisslerc723b722021-01-08 16:14:09 -06001SUMMARY = "a fast C/C++ compiler cache"
2DESCRIPTION = "ccache is a compiler cache. It speeds up recompilation \
3by caching the result of previous compilations and detecting when the \
4same compilation is being done again. Supported languages are C, C\+\+, \
5Objective-C and Objective-C++."
6HOMEPAGE = "http://ccache.samba.org"
7SECTION = "devel"
8
9LICENSE = "GPLv3+"
10LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=a66c581f855c1c408730fe5d171e3013"
11
12DEPENDS = "zstd"
13
14SRC_URI = "https://github.com/ccache/ccache/releases/download/v${PV}/${BP}.tar.gz \
15 file://0001-Improve-SIMD-detection-735.patch \
16 file://0002-Always-use-64bit-to-print-time_t.patch \
17 file://0001-blake3-Remove-asm-checks-for-sse-avx.patch \
18 "
19SRC_URI[sha256sum] = "cdeefb827b3eef3b42b5454858123881a4a90abbd46cc72cf8c20b3bd039deb7"
20
21UPSTREAM_CHECK_URI = "https://github.com/ccache/ccache/releases/"
22
23inherit cmake
24
25PATCHTOOL = "patch"
26
27BBCLASSEXTEND = "native nativesdk"