blob: a4f42e7bf4c62bbcc97fd89ba61ca2afcd4537da [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "wolfSSL Lightweight Embedded SSL/TLS Library"
2DESCRIPTION = "wolfSSL, formerly CyaSSL, is a lightweight SSL library written \
3 in C and optimized for embedded and RTOS environments. It can \
4 be up to 20 times smaller than OpenSSL while still supporting \
5 a full TLS client and server, up to TLS 1.3"
6HOMEPAGE = "https://www.wolfssl.com/products/wolfssl"
7BUGTRACKER = "https://github.com/wolfssl/wolfssl/issues"
8SECTION = "libs"
9LICENSE = "GPL-2.0-only"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
11
12PROVIDES += "cyassl"
13RPROVIDES:${PN} = "cyassl"
14
15SRC_URI = "git://github.com/wolfSSL/wolfssl.git;protocol=https;branch=master"
16SRCREV = "37884f864d6fd9b04f44677cb04da15d0c9d6526"
17
18S = "${WORKDIR}/git"
19
20inherit autotools
21
22BBCLASSEXTEND += "native nativesdk"