blob: a8279f57557aa390d3e750f8795de40befd589d9 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Utility for IPMI control"
2DESCRIPTION = "This package contains a utility for interfacing with devices that support \
3the Intelligent Platform Management Interface specification. IPMI is \
4an open standard for machine health, inventory, and remote power control. \
5\
6This utility can communicate with IPMI-enabled devices through either a \
7kernel driver such as OpenIPMI or over the RMCP LAN protocol defined in \
8the IPMI specification. IPMIv2 adds support for encrypted LAN \
9communications and remote Serial-over-LAN functionality. \
10\
11It provides commands for reading the Sensor Data Repository (SDR) and \
12displaying sensor values, displaying the contents of the System Event \
13Log (SEL), printing Field Replaceable Unit (FRU) information, reading and \
14setting LAN configuration, and chassis power control. \
15"
16
Andrew Geissler3eeda902023-05-19 10:14:02 -050017HOMEPAGE = "http://codeberg.org/IPMITool/ipmitool"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050018SECTION = "kernel/userland"
19
20LICENSE = "BSD-3-Clause"
21LIC_FILES_CHKSUM = "file://COPYING;md5=9aa91e13d644326bf281924212862184"
22
23DEPENDS = "openssl readline ncurses"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060024SRCREV = "ab5ce5baff097ebb6e2a17a171858be213ee68d3"
Andrew Geissler3eeda902023-05-19 10:14:02 -050025SRC_URI = "git://codeberg.org/ipmitool/ipmitool;protocol=https;branch=master \
Andrew Geissler87f5cff2022-09-30 13:13:31 -050026 ${IANA_ENTERPRISE_NUMBERS} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080027 "
Andrew Geissler87f5cff2022-09-30 13:13:31 -050028IANA_ENTERPRISE_NUMBERS ?= ""
29
30# Add these via bbappend if this database is needed by the system
Andrew Geissler3eeda902023-05-19 10:14:02 -050031#IANA_ENTERPRISE_NUMBERS = "http://www.iana.org/assignments/enterprise-numbers.txt;name=iana-enterprise-numbers;downloadfilename=iana-enterprise-numbers"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050032#SRC_URI[iana-enterprise-numbers.sha256sum] = "cdd97fc08325667434b805eb589104ae63f7a9eb720ecea73cb55110b383934c"
33
34S = "${WORKDIR}/git"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050035
Patrick Williamsac13d5f2023-11-24 18:59:46 -060036inherit autotools pkgconfig
Brad Bishop6e60e8b2018-02-01 10:27:11 -050037
Andrew Geissler87f5cff2022-09-30 13:13:31 -050038do_install:append() {
39 if [ -e ${WORKDIR}/iana-enterprise-numbers ]; then
40 install -Dm 0755 ${WORKDIR}/iana-enterprise-numbers ${D}${datadir}/misc/enterprise-numbers
41 fi
42}
43
Andrew Geissler595f6302022-01-24 19:11:47 +000044PACKAGES =+ "${PN}-ipmievd"
45FILES:${PN}-ipmievd += "${sbindir}/ipmievd"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050046FILES:${PN} += "${datadir}/misc"
Andrew Geissler595f6302022-01-24 19:11:47 +000047
Brad Bishop6e60e8b2018-02-01 10:27:11 -050048# --disable-dependency-tracking speeds up the build
49# --enable-file-security adds some security checks
50# --disable-intf-free disables FreeIPMI support - we don't want to depend on
51# FreeIPMI libraries, FreeIPMI has its own ipmitoool-like utility.
Patrick Williamsac13d5f2023-11-24 18:59:46 -060052# --disable-registry-download prevents the IANA numbers from being fetched
53# at build time, as it is not repeatable.
Brad Bishop6e60e8b2018-02-01 10:27:11 -050054#
Patrick Williamsac13d5f2023-11-24 18:59:46 -060055EXTRA_OECONF = "--disable-dependency-tracking --enable-file-security --disable-intf-free \
56 --disable-registry-download \
57 "
58