blob: 6fc2cf480925c5285a266542dc348918dba3bb14 [file] [log] [blame]
Patrick Williams2a254922023-08-11 09:48:11 -05001SUMMARY = "Simple construction, analysis and modification of binary data."
2HOMEPAGE = "https://github.com/scott-griffiths/bitstring"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=661f450e2c0aef39b4b15597333444a7"
5
Patrick Williams169d7bc2024-01-05 11:33:25 -06006SRC_URI[sha256sum] = "94f3f1c45383ebe8fd4a359424ffeb75c2f290760ae8fcac421b44f89ac85213"
Patrick Williams2a254922023-08-11 09:48:11 -05007
8PYPI_PACKAGE = "bitstring"
9
10inherit pypi python_poetry_core
11
12RDEPENDS:${PN} = "\
13 ${PYTHON_PN}-core \
14 ${PYTHON_PN}-io \
15 ${PYTHON_PN}-mmap \
16 ${PYTHON_PN}-numbers \
17"
18
19BBCLASSEXTEND = "native nativesdk"