Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | # Copyright (C) 2021 Khem Raj <raj.khem@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | SUMMARY = "Fastest Python implementation of JSON schema" |
| 5 | HOMEPAGE = "https://github.com/seznam/python-fastjsonschema" |
| 6 | LICENSE = "BSD-3-Clause" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=18950e8362b69c0c617b42b8bd8e7532" |
| 8 | |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 9 | SRCREV = "756540088687cda351390f687b92e602feaa7dc6" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 10 | PYPI_SRC_URI = "git://github.com/horejsek/python-fastjsonschema;protocol=https;branch=master" |
| 11 | |
| 12 | SRC_URI += "file://run-ptest" |
| 13 | |
| 14 | inherit ptest pypi setuptools3 |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | do_install_ptest() { |
| 19 | install -d ${D}${PTEST_PATH}/tests |
| 20 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 21 | } |
| 22 | |
| 23 | RDEPENDS:${PN}-ptest += "\ |
| 24 | python3-colorama \ |
| 25 | python3-jsonschema \ |
| 26 | python3-pylint \ |
| 27 | python3-pytest \ |
| 28 | python3-pytest-benchmark \ |
| 29 | python3-pytest-cache \ |
| 30 | " |
| 31 | RDEPENDS:${PN} += "\ |
| 32 | python3-core \ |
| 33 | python3-urllib3 \ |
| 34 | python3-numbers \ |
| 35 | python3-pickle \ |
| 36 | python3-json \ |
| 37 | " |
| 38 | |
| 39 | BBCLASSEXTEND = "native nativesdk" |