blob: 0dbb38d20012c79c8507d1e1082c78564494aff9 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Python bindings for libgpiod."
2
3LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later & CC-BY-SA-4.0"
4# The actual license files live in the upstream libgpiod from which the pypi
5# package is spun out.
6LIC_FILES_CHKSUM = "file://setup.py;beginline=237;endline=237;md5=f5ddb56912b7f20bf94aa4d1bdcd3533"
7
8SRC_URI += "file://run-ptest"
9
10SRC_URI[sha256sum] = "a33193d6cab79d252329f71666a35a3668e04f1f82bf9b93ee2c9ae852398b20"
11
12inherit setuptools3-base python_pep517 ptest pypi
13
14DEPENDS += " \
15 libgpiod \
16 python3-setuptools-native \
17"
18RDEPENDS:${PN} += " \
19 libgpiod (>= 2.1) \
20 python3-datetime \
21 python3-profile \
22"
23RDEPENDS:${PN}-ptest += " \
24 libgpiod-ptest \
25 python3-setuptools \
26"
27
28export LINK_SYSTEM_LIBGPIOD = "1"
29
30do_compile_ptest() {
31 setup_target_config
32 nativepython3 build_tests.py
33}
34
35do_install_ptest() {
36 install -d ${D}${PTEST_PATH}/gpiod-test/gpiosim
37 install -d ${D}${PTEST_PATH}/gpiod-test/procname
38 install -m 0644 ${S}/tests/*.py ${D}${PTEST_PATH}/gpiod-test/
39 install -m 0644 ${B}/tests/gpiosim/_ext* ${D}${PTEST_PATH}/gpiod-test/gpiosim
40 install -m 0644 ${S}/tests/gpiosim/*.py ${D}${PTEST_PATH}/gpiod-test/gpiosim
41 install -m 0644 ${B}/tests/procname/_ext* ${D}${PTEST_PATH}/gpiod-test/procname
42 install -m 0644 ${S}/tests/procname/*.py ${D}${PTEST_PATH}/gpiod-test/procname
43}
44
45INSANE_SKIP:${PN}-ptest += "buildpaths"