blob: b926484db03e0bee3de8cba9b659205f7b461c69 [file] [log] [blame]
Patrick Williamsdb4c27e2022-08-05 08:10:29 -05001SUMMARY = "Functors, Applicatives, And Monads in Python"
2HOMEPAGE = "https://github.com/dbrattli/oslash"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://README.md;md5=ed79d2637878dfe97de89e357b5c02dd"
5
6DEPENDS += "\
7 ${PYTHON_PN}-pip-native \
8 ${PYTHON_PN}-pytest-runner-native\
9"
10
11SRC_URI[sha256sum] = "868aeb58a656f2ed3b73d9dd6abe387b20b74fc9413d3e8653b615b15bf728f3"
12
13PYPI_PACKAGE = "OSlash"
14
15inherit pypi setuptools3
16
Patrick Williamsb542dec2023-06-09 01:26:37 -050017RDEPENDS:${PN} += " \
18 python3-json \
19 python3-typing-extensions \
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050020"
21
22BBCLASSEXTEND = "native nativesdk"