blob: 5e5f0c92f50b9f7455404731d21472fbb6b3f627 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Python interface for c-ares"
2DESCRIPTION = "\
3pycares is a Python module which provides an interface to c-ares. c-ares is \
4a C library that performs DNS requests and name resolutions asynchronously."
5HOMEPAGE = "https://github.com/saghul/pycares"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=b1538fcaea82ebf2313ed648b96c69b1"
8
9SRC_URI[sha256sum] = "f47579d508f2f56eddd16ce72045782ad3b1b3b678098699e2b6a1b30733e1c2"
10
11PYPI_PACKAGE = "pycares"
12
13inherit pypi setuptools3
14
15DEPENDS += "${PYTHON_PN}-cffi-native"
16
17RDEPENDS:${PN} += " \
18 ${PYTHON_PN}-cffi \
19 ${PYTHON_PN}-idna \
20"