blob: 739df2a1ba9584c19b785905b98c20d6d66ca174 [file] [log] [blame]
Andrew Geissler8f840682023-07-21 09:09:43 -05001# SPDX-License-Identifier: MIT
2# Copyright (C) 2023 iris-GmbH infrared & intelligent sensors
3
4SUMMARY = "pyproject-api aims to abstract away interaction with pyproject.toml style projects in a flexible way."
5HOMEPAGE = "https://pyproject-api.readthedocs.io"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=11610a9d8fd95649cf8159be12b98cb7"
8
Andrew Geissler220dafd2023-10-04 10:18:08 -05009SRC_URI[sha256sum] = "1817dc018adc0d1ff9ca1ed8c60e1623d5aaca40814b953af14a9cf9a5cae538"
Andrew Geissler8f840682023-07-21 09:09:43 -050010
11PYPI_PACKAGE = "pyproject_api"
12
13BBCLASSEXTEND = "native nativesdk"
14inherit pypi python_hatchling
15
16DEPENDS += "\
17 ${PYTHON_PN}-hatch-vcs-native \
18"
19
20RDEPENDS:${PN} += "\
21 ${PYTHON_PN}-packaging \
22 ${PYTHON_PN}-tomli \
23"