Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Xlib: C Language X Interface library" |
| 2 | |
| 3 | DESCRIPTION = "This package provides a client interface to the X Window \ |
| 4 | System, otherwise known as 'Xlib'. It provides a complete API for the \ |
| 5 | basic functions of the window system." |
| 6 | |
| 7 | require xorg-lib-common.inc |
| 8 | |
| 9 | LICENSE = "MIT & BSD-1-Clause & HPND & HPND-sell-variant & ISC" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=1d49cdd2b386c5db11ec636d680b7116" |
| 11 | |
| 12 | DEPENDS += "xorgproto \ |
| 13 | xtrans \ |
| 14 | libxcb \ |
| 15 | xorgproto-native \ |
Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame] | 16 | autoconf-archive-native \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 17 | " |
| 18 | |
| 19 | PROVIDES = "virtual/libx11" |
| 20 | |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 21 | PE = "1" |
| 22 | |
| 23 | XORG_PN = "libX11" |
| 24 | |
Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame] | 25 | SRC_URI += "file://disable_tests.patch" |
| 26 | |
Andrew Geissler | 2013739 | 2023-10-12 04:59:14 -0600 | [diff] [blame] | 27 | SRC_URI[sha256sum] = "05f267468e3c851ae2b5c830bcf74251a90f63f04dd7c709ca94dc155b7e99ee" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 28 | |
| 29 | inherit gettext |
| 30 | |
| 31 | EXTRA_OECONF += "--with-keysymdefdir=${STAGING_INCDIR}/X11/ --disable-xf86bigfont" |
| 32 | EXTRA_OEMAKE += 'CWARNFLAGS=""' |
| 33 | |
| 34 | PACKAGECONFIG ??= "xcms" |
| 35 | PACKAGECONFIG[xcms] = "--enable-xcms,--disable-xcms" |
| 36 | |
| 37 | PACKAGES =+ "${PN}-xcb" |
| 38 | |
| 39 | FILES:${PN} += "${datadir}/X11/XKeysymDB ${datadir}/X11/XErrorDB ${datadir}/X11/Xcms.txt" |
| 40 | FILES:${PN}-xcb += "${libdir}/libX11-xcb.so.*" |
| 41 | FILES:${PN}-locale += "${datadir}/X11/locale ${libdir}/X11/locale" |
| 42 | |
| 43 | BBCLASSEXTEND = "native nativesdk" |