blob: d1197312ec3ad693921a08287781298c3c2dbee5 [file] [log] [blame]
Grant Williams02cb47e2022-06-08 14:11:16 -05001SUMMARY = "Power Cycle by Hotswap Controller"
2DESCRIPTION = "Power Cycle by Hotswap Controller Daemon"
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7inherit systemd
8
9DEPENDS += "systemd"
10RDEPENDS:${PN} += "bash"
11
12SRC_URI += " file://hotswap-power-cycle.service"
13
14do_install() {
15 install -d ${D}${systemd_unitdir}/system/
16 install -m 0644 ${WORKDIR}/hotswap-power-cycle.service ${D}${systemd_unitdir}/system/hotswap-power-cycle.service
17}
18
19SYSTEMD_PACKAGES = "${PN}"
20SYSTEMD_SERVICE:${PN} = " hotswap-power-cycle.service"