Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "A microframework based on Werkzeug, Jinja2 and good intentions" |
| 2 | DESCRIPTION = "\ |
| 3 | Flask is a microframework for Python based on Werkzeug, Jinja 2 and good \ |
| 4 | intentions. And before you ask: It’s BSD licensed!" |
| 5 | HOMEPAGE = "https://github.com/mitsuhiko/flask/" |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 6 | LICENSE = "BSD-3-Clause" |
Brad Bishop | 87b3cb8 | 2019-11-15 16:35:37 -0500 | [diff] [blame] | 7 | LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 8 | |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 9 | SRC_URI[sha256sum] = "1c4c257b1892aec1398784c63791cbaa43062f1f7aeb555c4da961b20ee68f55" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 10 | |
| 11 | PYPI_PACKAGE = "Flask" |
| 12 | |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 13 | inherit pypi setuptools3 |
| 14 | |
| 15 | CLEANBROKEN = "1" |
| 16 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 17 | RDEPENDS:${PN} = " \ |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 18 | ${PYTHON_PN}-werkzeug \ |
| 19 | ${PYTHON_PN}-jinja2 \ |
| 20 | ${PYTHON_PN}-itsdangerous \ |
| 21 | ${PYTHON_PN}-click \ |
| 22 | ${PYTHON_PN}-profile \ |
| 23 | " |