Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | DESCRIPTION = "Devilspie2 is a window matching utility, allowing the user to perform scripted actions on windows as they are created" |
| 2 | HOMEPAGE = "http://www.gusnan.se/devilspie2" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 3 | LICENSE = "GPL-3.0-only" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=00aefaa50aad75c21367df66102d542c \ |
| 5 | file://GPL3.txt;md5=d32239bcb673463ab874e80d47fae504" |
| 6 | |
| 7 | DEPENDS = "gtk+ glib-2.0 libwnck libxinerama lua virtual/libx11" |
| 8 | |
| 9 | PV .= "+git${SRCPV}" |
| 10 | |
| 11 | SRCREV = "b9d7ad9c09a5fb17a1562ee1d892798c646e9ec9" |
| 12 | |
| 13 | SRC_URI = "git://github.com/dsalt/devilspie2;branch=master;protocol=https \ |
| 14 | file://default.lua \ |
| 15 | file://devilspie2.desktop \ |
| 16 | " |
| 17 | |
| 18 | S = "${WORKDIR}/git" |
| 19 | |
| 20 | inherit features_check pkgconfig gettext |
| 21 | |
| 22 | REQUIRED_DISTRO_FEATURES = "x11" |
| 23 | |
| 24 | do_compile() { |
| 25 | export GTK2=1 |
| 26 | oe_runmake CC="${CC}" CPPFLAGS="${CPPFLAGS}" LDFLAGS=" -ldl -lm ${LDFLAGS}" |
| 27 | } |
| 28 | |
| 29 | do_install() { |
| 30 | oe_runmake DESTDIR="${D}" PREFIX="${prefix}" install |
| 31 | install -d ${D}/${sysconfdir}/devilspie2 |
| 32 | install -m 644 ${WORKDIR}/default.lua ${D}/${sysconfdir}/devilspie2 |
| 33 | install -d ${D}/${sysconfdir}/xdg/autostart |
| 34 | install -m 644 ${WORKDIR}/devilspie2.desktop ${D}/${sysconfdir}/xdg/autostart |
| 35 | } |