blob: 1b6e926b93c03e5630dc83d75c488d77ebf93ac4 [file] [log] [blame]
John Wangaf0bc6e2018-11-29 11:22:01 +08001SUMMARY = "Inspur On5263 board wiring"
2DESCRIPTION = "Board wiring information for the On5263 system."
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${INSPURBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
6
7inherit allarch
8inherit setuptools
9inherit pythonnative
10
11PROVIDES += "virtual/obmc-inventory-data"
12RPROVIDES_${PN} += "virtual-obmc-inventory-data"
13
14DEPENDS += "python"
15
16S = "${WORKDIR}"
17SRC_URI += "file://On5263m5.py"
18
19# the following is unnecessary.
20python() {
21 machine = d.getVar('MACHINE', True).capitalize() + '.py'
22 d.setVar('_config_in_skeleton', machine)
23}
24
25do_make_setup() {
26 cp ${S}/${_config_in_skeleton} \
27 ${S}/obmc_system_config.py
28 cat <<EOF > ${S}/setup.py
29from distutils.core import setup
30
31setup(name='${BPN}',
32 version='${PR}',
33 py_modules=['obmc_system_config'],
34 )
35EOF
36}
37
38addtask make_setup after do_patch before do_configure