blob: 62ecbdf91c90c5ddb0e6e72a576399a0af9d9a13 [file] [log] [blame]
Brad Bishop286d45c2018-10-02 15:21:57 -04001
2# enable the overrides for the context of the conf only
3OVERRIDES .= ":qemuboot-xilinx"
4
Brad Bishop286d45c2018-10-02 15:21:57 -04005# Default machine targets for Xilinx QEMU (FDT Generic)
Andrew Geisslera9ff2b32020-10-16 10:11:54 -05006# Allow QB_MACHINE to be overridden by a BSP config
7QB_MACHINE ?= "${QB_MACHINE_XILINX}"
8
9QB_MACHINE_XILINX_aarch64 = "-machine arm-generic-fdt"
10QB_MACHINE_XILINX_arm = "-machine arm-generic-fdt-7series"
11QB_MACHINE_XILINX_microblaze = "-machine microblaze-fdt-plnx"
Brad Bishop286d45c2018-10-02 15:21:57 -040012
13# defaults
14QB_DEFAULT_KERNEL ?= "none"
15
16inherit qemuboot
17
18# rewrite the qemuboot with the custom sysroot bindir
19python do_write_qemuboot_conf_append() {
20 val = os.path.join(d.getVar('BASE_WORKDIR'), d.getVar('BUILD_SYS'), 'qemu-xilinx-helper-native/1.0-r1/recipe-sysroot-native/usr/bin/')
21 cf.set('config_bsp', 'STAGING_BINDIR_NATIVE', '%s' % val)
22
23 # write out the updated version from this append
24 with open(qemuboot, 'w') as f:
25 cf.write(f)
26}
27