blob: 1f6232e43c4b06d6badb37f04cbff06dcd561388 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Shadow utils requirements for useradd.bbclass"
Brad Bishopf3f93bb2019-10-16 14:33:32 -04002HOMEPAGE = "http://github.com/shadow-maint/shadow"
3BUGTRACKER = "http://github.com/shadow-maint/shadow/issues"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05004SECTION = "base utils"
5LICENSE = "BSD | Artistic-1.0"
6LIC_FILES_CHKSUM = "file://login.defs_shadow-sysroot;md5=25e2f2de4dfc8f966ac5cdfce45cd7d5"
7
8DEPENDS = "base-passwd"
9
10PR = "r3"
11
12# The sole purpose of this recipe is to provide the /etc/login.defs
13# file for the target sysroot - needed so the shadow-native utilities
14# can add custom users/groups for recipes that use inherit useradd.
15SRC_URI = "file://login.defs_shadow-sysroot"
16
Patrick Williamsc124f4f2015-09-15 14:41:29 -050017S = "${WORKDIR}"
18
19do_install() {
20 install -d ${D}${sysconfdir}
Patrick Williamsc0f7c042017-02-23 20:41:17 -060021 install -p -m 644 ${S}/login.defs_shadow-sysroot ${D}${sysconfdir}/login.defs
Patrick Williamsc124f4f2015-09-15 14:41:29 -050022}
23
Patrick Williamsc0f7c042017-02-23 20:41:17 -060024SYSROOT_DIRS += "${sysconfdir}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050025
26# don't create any packages
Brad Bishopf3f93bb2019-10-16 14:33:32 -040027# otherwise: dbus-dev depends on shadow-sysroot-dev which depends on shadow-sysroot
Patrick Williamsc124f4f2015-09-15 14:41:29 -050028# and this has another copy of /etc/login.defs already provided by shadow
29PACKAGES = ""
Andrew Geissleraf5e4ef2020-10-16 10:22:50 -050030
31inherit nopackages