blob: d8096de5af5b51c141a76419f4ce844d1b60404b [file] [log] [blame]
Andrew Geissleraf5e4ef2020-10-16 10:22:50 -05001SUMMARY = "Boost.Build"
2SECTION = "devel"
3
4LICENSE = "BSL-1.0"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
6
7SRC_URI = "git://github.com/boostorg/build;protocol=https"
8SRCREV = "632ea768f3eb225b4472c5ed6d20afee708724ad"
9
10inherit native
11
12S = "${WORKDIR}/git"
13
14do_compile() {
15 ./bootstrap.sh
16}
17
18do_install() {
19 ./b2 install --prefix=${prefix} staging-prefix=${D}${prefix}
20}
21
22# The build is either release mode (pre-stripped) or debug (-O0).
23INSANE_SKIP_${PN} = "already-stripped"