blob: 98829765c2a3d59bda85a3b5e95c6dd207c290f7 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "sdbus-c++"
2DESCRIPTION = "High-level C++ D-Bus library designed to provide easy-to-use yet powerful API in modern C++"
3
4SECTION = "libs"
5
6LICENSE = "LGPLv2.1"
7LIC_FILES_CHKSUM = "file://COPYING;md5=1803fa9c2c3ce8cb06b4861d75310742"
8
9inherit cmake pkgconfig systemd ptest
10
11PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'with-external-libsystemd', 'with-builtin-libsystemd', d)} \
12 ${@bb.utils.contains('PTEST_ENABLED', '1', 'with-tests', '', d)}"
13PACKAGECONFIG[with-builtin-libsystemd] = ",,sdbus-c++-libsystemd,libcap"
14PACKAGECONFIG[with-external-libsystemd] = ",,systemd,libsystemd"
15PACKAGECONFIG[with-tests] = "-DBUILD_TESTS=ON -DTESTS_INSTALL_PATH=${libdir}/${BPN}/tests,-DBUILD_TESTS=OFF"
16
17DEPENDS += "expat"
18
Andrew Geisslerd688a012020-09-18 13:36:00 -050019SRCREV = "6e8e5aadb674cccea5bdd55141db5dad887fbacd"
Andrew Geissler82c905d2020-04-13 13:39:40 -050020SRC_URI = "git://github.com/Kistler-Group/sdbus-cpp.git;protocol=https;branch=master"
21SRC_URI += "file://run-ptest"
22
23EXTRA_OECMAKE = "-DBUILD_CODE_GEN=ON \
24 -DBUILD_DOC=ON \
25 -DBUILD_DOXYGEN_DOC=OFF"
26
27S = "${WORKDIR}/git"
28
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050029do_install_append() {
30 if ! ${@bb.utils.contains('PTEST_ENABLED', '1', 'true', 'false', d)}; then
31 rm -rf ${D}${sysconfdir}/dbus-1
32 fi
33}
34
35PTEST_PATH = "${libdir}/${BPN}/tests"
36FILES_${PN}-ptest =+ "${sysconfdir}/dbus-1/system.d/"
Andrew Geissler82c905d2020-04-13 13:39:40 -050037FILES_${PN}-dev += "${bindir}/sdbus-c++-xml2cpp"