blob: f81cf7f0315caac92104ad8a100f57227b9ad9c9 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Library to handle input devices in Wayland compositors"
2DESCRIPTION = "libinput is a library to handle input devices in Wayland \
3compositors and to provide a generic X.Org input driver. It provides \
4device detection, device handling, input device event processing and \
5abstraction so minimize the amount of custom input code compositors need to \
6provide the common set of functionality that users expect."
7HOMEPAGE = "http://www.freedesktop.org/wiki/Software/libinput/"
8SECTION = "libs"
9
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://COPYING;md5=1f2ea9ebff3a2c6d458faf58492efb63"
12
Andrew Geisslerc182c622020-05-15 14:13:32 -050013DEPENDS = "libevdev udev mtdev libcheck"
Andrew Geissler82c905d2020-04-13 13:39:40 -050014
15SRC_URI = "http://www.freedesktop.org/software/${BPN}/${BP}.tar.xz \
Andrew Geisslerc182c622020-05-15 14:13:32 -050016 file://run-ptest \
Andrew Geissler82c905d2020-04-13 13:39:40 -050017 file://determinism.patch \
18 "
Andrew Geisslerd25ed322020-06-27 00:28:28 -050019SRC_URI[md5sum] = "b2388a1d6f0dcc944b49bc7239a53be8"
20SRC_URI[sha256sum] = "aeedea216a6317ddc6e27c3d54f26b987078780db6a8320cc09e19c25b307f1c"
Andrew Geissler82c905d2020-04-13 13:39:40 -050021
22UPSTREAM_CHECK_REGEX = "libinput-(?P<pver>\d+\.\d+\.(?!9\d+)\d+)"
23
Andrew Geisslerc182c622020-05-15 14:13:32 -050024inherit meson pkgconfig lib_package ptest
25
26# Patch out build directory, otherwise it leaks into ptest binary
27do_configure_append() {
28 sed -i -e "s,${WORKDIR},,g" config.h
29 if [ -e "litest-config.h" ]; then
30 sed -i -e "s,${WORKDIR},,g" litest-config.h
31 fi
32}
Andrew Geissler82c905d2020-04-13 13:39:40 -050033
34PACKAGECONFIG ??= ""
35PACKAGECONFIG[libwacom] = "-Dlibwacom=true,-Dlibwacom=false,libwacom"
36PACKAGECONFIG[gui] = "-Ddebug-gui=true,-Ddebug-gui=false,cairo gtk+3"
37
38UDEVDIR = "`pkg-config --variable=udevdir udev`"
39
40EXTRA_OEMESON += "-Dudev-dir=${UDEVDIR} \
41 -Ddocumentation=false \
Andrew Geisslerc182c622020-05-15 14:13:32 -050042 ${@bb.utils.contains('PTEST_ENABLED', '1', '-Dtests=true -Dinstall-tests=true', '-Dtests=false -Dinstall-tests=false', d)} \
Andrew Geissler82c905d2020-04-13 13:39:40 -050043 -Dzshcompletiondir=no"
44
45# package name changed in 1.8.1 upgrade: make sure package upgrades work
46RPROVIDES_${PN} = "libinput"
47RREPLACES_${PN} = "libinput"
48RCONFLICTS_${PN} = "libinput"
49
Andrew Geisslerc182c622020-05-15 14:13:32 -050050FILES_${PN}-ptest += "${libexecdir}/libinput/libinput-test-suite"