blob: c6f36aea70fcd1d52ef9493d07d93bec3f562ce9 [file] [log] [blame]
Jeremy Kerr708f0cc2019-12-20 12:02:36 +08001SUMMARY = "MCTP stack"
2DESCRIPTION = "MCTP library implementing the MCTP base specification"
3PR = "r1"
4PV = "1.0+git${SRCPV}"
5
6inherit systemd
7inherit autotools pkgconfig
8
9HOMEPAGE = "https://github.com/openbmc/libmctp"
10LICENSE = "Apache-2.0"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=0d30807bb7a4f16d36e96b78f9ed8fae"
12SRC_URI = "git://github.com/openbmc/libmctp \
13 file://default"
Andrew Geisslerb0280282020-07-07 05:01:46 +000014SRCREV = "3ac70d62571953be172a0d16976e383490d25059"
Jeremy Kerr708f0cc2019-12-20 12:02:36 +080015CONFFILES_${PN} = "${sysconfdir}/default/mctp"
16
17DEPENDS += "autoconf-archive-native \
18 systemd \
19 "
20
21SYSTEMD_SERVICE_${PN} = "mctp-demux.service"
22
23do_install_append() {
24 install -d ${D}${sysconfdir}/default
25 install -m 0644 ${WORKDIR}/default ${D}${sysconfdir}/default/mctp
26}
27
28S = "${WORKDIR}/git"