blob: f18e55caa8cedad4903a0dcd4938c5cc7dd00bd0 [file] [log] [blame]
Brad Bishop5104c2f2016-08-30 00:46:40 -04001SUMMARY = "Phosphor DBUS to REST WSGI Application"
2DESCRIPTION = "Phosphor DBUS to REST WSGI Application."
Brad Bishop5ef5aa32015-10-27 17:13:26 -04003PR = "r1"
Brad Bishop5ef5aa32015-10-27 17:13:26 -04004
5inherit allarch
6inherit obmc-phosphor-systemd
7inherit setuptools
Ratan Guptadf7dfd42016-10-01 14:57:15 -05008inherit obmc-phosphor-discovery-service
Brad Bishop5ef5aa32015-10-27 17:13:26 -04009
Patrick Williamsa981b102017-03-01 21:25:36 -060010require phosphor-rest.inc
11
Dhruvaraj Subhashchandran1ea01342017-10-12 04:43:17 -050012RRECOMMENDS_${PN} += " \
13 virtual-obmc-wsgihost \
14 python-gevent-websocket \
15 "
Brad Bishop5104c2f2016-08-30 00:46:40 -040016
Brad Bishop5ef5aa32015-10-27 17:13:26 -040017RDEPENDS_${PN} += " \
18 python-xml \
19 python-dbus \
Brad Bishop12e3d602016-10-05 20:10:23 -040020 phosphor-mapper \
Brad Bishop18667542016-04-15 09:41:54 -040021 python-bottle \
22 python-spwd \
Brad Bishop376b0652016-08-29 21:47:04 -040023 pyphosphor-utils \
24 pyphosphor-dbus \
Brad Bishop5104c2f2016-08-30 00:46:40 -040025 pyphosphor-wsgi-apps-ns \
Brad Bishop5ef5aa32015-10-27 17:13:26 -040026 "
Nagaraju Gorugantib04fcb22018-06-01 00:19:42 -050027SRC_URI += "file://url_config.json \
28 "
29
30FILES_${PN}_append = " ${datadir}/rest-dbus/url_config.json"
Brad Bishop5ef5aa32015-10-27 17:13:26 -040031
Brad Bishop5104c2f2016-08-30 00:46:40 -040032S = "${WORKDIR}/git/module"
33SYSTEMD_SERVICE_${PN} = ""
34SYSTEMD_OVERRIDE_${PN} += "rest-dbus.conf:obmc-mapper.target.d/rest-dbus.conf"
35SYSTEMD_ENVIRONMENT_FILE_${PN} += "obmc/wsgi_app"
Ratan Guptadf7dfd42016-10-01 14:57:15 -050036REGISTERED_SERVICES_${PN} += "phosphor_rest:tcp:443"
Nagaraju Gorugantib04fcb22018-06-01 00:19:42 -050037
38do_install_append(){
39 install -d ${D}${datadir}/rest-dbus
40 install -m 0644 -D ${WORKDIR}/url_config.json \
41 ${D}${datadir}/rest-dbus/url_config.json
42}