blob: 5d5e38a7bcc8d0fdddff77b30d25dfdfee0c5ed5 [file] [log] [blame]
Andrew Geissler68be0732020-04-14 11:25:29 -05001inherit update-alternatives
2
3ALTERNATIVE_${PN}-core += "python"
4ALTERNATIVE_LINK_NAME[python] = "${bindir}/python"
5ALTERNATIVE_TARGET[python] = "${bindir}/python3"
Andrew Geisslerb2808372020-04-14 11:26:24 -05006
7# Even though python3 is built with --without-ensurepip, it still installs
8# a large, compressed version of pip. Remove it to free up the space.
9do_install_append_class-target() {
10 rm -rf ${D}${libdir}/python${PYTHON_MAJMIN}/ensurepip
11}