blob: c42b689edd8c22bc70bb285ed92fc4cd726a1680 [file] [log] [blame]
Michael Shencf7d39d2021-08-05 10:14:46 +08001SUMMARY = "GPIO control library for bash scripts"
2DESCRIPTION = "GPIO control library for bash scripts."
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
5PR = "r1"
6
7SRC_URI += "file://lib.sh"
8
Michael Shen9e1a3ae2021-08-18 14:07:10 +08009RDEPENDS:${PN} = "bash"
Michael Shencf7d39d2021-08-05 10:14:46 +080010
11do_install() {
12 install -d ${D}${datadir}/gpio-ctrl
13 install -m 0755 ${WORKDIR}/lib.sh ${D}${datadir}/gpio-ctrl/
14}