blob: 2281192fe4e773b689218f4845733856f7d15a4a [file] [log] [blame]
Ben Paia8c7bfc2020-03-31 16:34:40 +08001SUMMARY = "Wistron OEM commands"
2DESCRIPTION = "Wistron OEM commands"
3HOMEPAGE = "https://github.com/openbmc/wistron-ipmi-oem"
4PR = "r1"
5PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
8
9inherit autotools pkgconfig
10inherit obmc-phosphor-ipmiprovider-symlink
11
12DEPENDS += "phosphor-ipmi-host"
13DEPENDS += "autoconf-archive-native"
14
15S = "${WORKDIR}/git"
16SRC_URI = "git://github.com/openbmc/wistron-ipmi-oem"
17SRCREV = "44cee319dd113335a7885a1ff63a287dc7706682"
18
19FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
20FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
21FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
22
23HOSTIPMI_PROVIDER_LIBRARY += "libwistronoem.so"