blob: 015b1ae0ecf70bc11631b44202af9e10c82de951 [file] [log] [blame]
Matt Spinlerb45c1822018-03-26 16:23:38 -05001SUMMARY = "IBM DBus Interfaces"
2DESCRIPTION = "Generated bindings, using sdbus++, for the IBM YAML"
3PR = "r1"
4
5S = "${WORKDIR}/git"
6
7inherit autotools pkgconfig
8inherit obmc-phosphor-license
9inherit pythonnative
10inherit phosphor-dbus-yaml
11
12DEPENDS += "autoconf-archive-native"
13DEPENDS += "sdbus++-native"
14
15SRC_URI += "git://github.com/openbmc/ibm-dbus-interfaces"
16SRCREV = "71b0cb84b35533bf75d07940e93c7b8ceb7b8b12"
17
18DEPENDS_remove_class-native = "sdbus++-native"
19DEPENDS_remove_class-nativesdk = "sdbus++-native"
20
21PACKAGECONFIG ??= "libibm_dbus"
22PACKAGECONFIG[libibm_dbus] = " \
23 --enable-libibm_dbus, \
24 --disable-libibm_dbus, \
25 systemd sdbusplus, \
26 libsystemd sdbusplus \
27 "
28
29PACKAGECONFIG_remove_class-native = "libibm_dbus"
30PACKAGECONFIG_remove_class-nativesdk = "libibm_dbus"
31
32BBCLASSEXTEND += "native nativesdk"