Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | require gdb-common.inc |
| 2 | |
| 3 | inherit gettext pkgconfig |
| 4 | |
| 5 | #LDFLAGS:append = " -s" |
| 6 | #export CFLAGS:append=" -L${STAGING_LIBDIR}" |
| 7 | |
| 8 | # cross-canadian must not see this |
| 9 | PACKAGES =+ "gdbserver" |
| 10 | FILES:gdbserver = "${bindir}/gdbserver" |
| 11 | |
| 12 | require gdb.inc |
| 13 | |
| 14 | inherit python3-dir |
| 15 | |
| 16 | EXTRA_OEMAKE:append:libc-musl = "\ |
| 17 | gt_cv_func_gnugettext1_libc=yes \ |
| 18 | gt_cv_func_gnugettext2_libc=yes \ |
| 19 | gl_cv_func_working_strerror=yes \ |
| 20 | gl_cv_func_strerror_0_works=yes \ |
| 21 | gl_cv_func_gettimeofday_clobber=no \ |
| 22 | " |
| 23 | |
| 24 | do_configure:prepend() { |
| 25 | if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then |
| 26 | cat > ${WORKDIR}/python << EOF |
| 27 | #!/bin/sh |
| 28 | case "\$2" in |
| 29 | --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}/" ;; |
| 30 | --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}${PYTHON_ABI}" ;; |
| 31 | --exec-prefix) echo "${exec_prefix}" ;; |
| 32 | *) exit 1 ;; |
| 33 | esac |
| 34 | exit 0 |
| 35 | EOF |
| 36 | chmod +x ${WORKDIR}/python |
| 37 | fi |
| 38 | } |
| 39 | |