blob: 965e4e995a4ed8f91d1131d1dc142f5be90de436 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION = "efenniht illume theme - Efenniht was devised to be clean \
2and neutral. Its name (which means equinox) comes from the chromatic duality \
3that was decided at the very beginning, with a dark theme (black and orange) \
4and a bright one (white and blue) to be developed so that more people feel \
5comfortable using it. Efenniht uses few animations, discrete contrasts between \
6shades of gray and fine lines (colored) that outline the selected elements."
7SECTION = "e/utils"
8HOMEPAGE = "http://trac.enlightenment.org/e/wiki/Themes#Efenniht"
9DEPENDS = "edje-native"
10RDEPENDS_${PN} = "e-wm"
11RSUGGESTS_${PN} = "elementary-theme-efenniht"
12LICENSE = "MIT & BSD"
13LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=f523ab5986cc79b52a90d2ac3d5454a2"
14
15SRCREV = "${EFL_SRCREV}"
16PV = "0.0+svnr${SRCPV}"
17
18inherit e-base allarch
19
20SRCNAME = "efenniht"
21SRC_URI = "${E_SVN}/trunk/THEMES;module=${SRCNAME};protocol=http \
22 file://LICENSE \
23"
24S = "${WORKDIR}/${SRCNAME}"
25
26do_compile() {
27 ${STAGING_BINDIR_NATIVE}/edje_cc -id ${S}/images ${S}/efenniht.edc -o ${S}/efenniht.edj
28}
29
30do_install() {
31 install -d ${D}${datadir}/enlightenment/data/themes/
32 install -m 0644 ${S}/efenniht.edj ${D}${datadir}/enlightenment/data/themes/
33}
34
35FILES_${PN} = "${datadir}/enlightenment/data/themes/"