blob: 297cbd52369944900cdfa1ad9955a97deefb4635 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Enjoy music player"
2LICENSE = "LGPLv3"
3LIC_FILES_CHKSUM = "file://COPYING;md5=6a6a8e020838b23406c81b19c1d46df6"
4DEPENDS = "evas ecore edje elementary emotion lightmediascanner eldbus gst-plugins-good"
5
6SRCREV = "aa8fec69e885eec048a849c2b34059ec58404e02"
7PV = "0.1.0+gitr${SRCPV}"
8
9#1st needed for all formats
10#2nd needed for mp3 playback
11#3d needed for ogg playback
12#4th needed for flac playback
13#5th needed binary to create db
14RDEPENDS_${PN} += "\
15 gst-plugins-base-typefindfunctions gst-plugins-base-playbin gst-plugins-base-volume gst-plugins-base-decodebin2 gst-plugins-good-autodetect \
16 gst-plugins-base-ogg gst-plugins-base-ivorbisdec \
17 gst-plugins-good-flac \
18 lightmediascanner-test \
19"
20
21inherit e gettext
22SRC_URI = " \
23 git://git.enlightenment.org/apps/enjoy.git \
24 file://0001-always-use-position-as-percent-and-define-a-1-second.patch \
25 file://configure.patch \
26"
27S = "${WORKDIR}/git"
28
29FILES_${PN} += "${datadir}/icons/"
30
31EXTRA_OECONF = "\
32 --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
33"
34
35PACKAGECONFIG[mad] = ",,gst-plugins-ugly,gst-plugins-ugly-mad"
36PACKAGECONFIG[id3demux] = ",,,gst-plugins-good-id3demux"
37
38do_configure_prepend() {
39 autopoint || touch config.rpath
40}
41
42pkg_postinst_${PN} () {
43 echo "enjoy: SCAN and LIBRARY MANAGER are not implemeted yet!"
44 echo "enjoy: Meanwhile please run:"
45 echo "enjoy: test-lms -m mono -p id3 -i 5000 -s /path/to/your/music/dir /home/root/.config/enjoy/media.db"
46 echo "enjoy:"
47 echo "enjoy: Use test-lms -P to see available formats that can be scanned"
48}