blob: f70860154fa458f558928e63cbdbdd22e4baeaa9 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001LICENSE = "LGPL-2.0"
2LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
3
4PV = "0.0.1+svnr${SRCPV}"
5
6require e-module.inc
7
8DEPENDS += "elementary exalt edje-native"
9
10CFLAGS += " -I${STAGING_INCDIR}/exalt -I${STAGING_INCDIR}/exalt_dbus"
11
12do_configure_prepend() {
13 sed -i -e /po/d ${S}/configure.ac
14 sed -i -e s:\ po::g ${S}/Makefile.am
15}
16
17FILES_${PN} += "${libdir}/enlightenment/modules/*/*.desktop \
18 ${libdir}/enlightenment/modules/*/*.edj \
19 ${libdir}/enlightenment/modules/*/*/*.so"
20
21FILES_${PN}-staticdev += "${libdir}/enlightenment/modules/*/*/*.a"
22FILES_${PN}-dev += "${libdir}/enlightenment/modules/*/*/*.la"
23FILES_${PN}-dbg += "${libdir}/enlightenment/modules/*/*/.debug"
24
25SRC_URI += "file://configure.patch"