blob: eff8586173e781f656e991e6a3ea74a51d435243 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "EFL-based weather widget library"
2LICENSE = "LGPL-2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24 \
4 file://COPYING-PLAIN;md5=c910b645eda0005ccec46f75203dc96e"
5
6DEPENDS = "ecore edje"
7PV = "0.0.0+svnr${SRCPV}"
8SRCREV = "${EFL_SRCREV}"
9
10inherit efl
11SRC_URI = "${E_SVN}/trunk/PROTO;module=${SRCNAME};protocol=http;scmdata=keep"
12S = "${WORKDIR}/${SRCNAME}"
13
14EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
15
16RSUGGESTS_${PN} = "elementary-tests"
17
18do_compile_append() {
19 sed -i -e s:${STAGING_DIR_TARGET}::g \
20 -e s:/${TARGET_SYS}::g \
21 eweather.pc
22}
23
24PACKAGES += "${PN}-plugins"
25
26FILES_${PN}-themes = "\
27 ${datadir} \
28"
29
30FILES_${PN}-plugins = "\
31 ${libdir}/eweather/plugins/*.so \
32"
33
34FILES_${PN}-dbg += "\
35 ${libdir}/eweather/plugins/.debug \
36"
37
38FILES_${PN}-dev += "\
39 ${libdir}/eweather/plugins/*.a \
40 ${libdir}/eweather/plugins/*.la \
41"
42
43RRECOMMENDS_${PN} = "\
44 ${PN}-themes \
45 ${PN}-plugins \
46"