blob: 32ebec83d6249156b68a0d556cd3ed8c2d224e0f [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "LogFS Programs: used to create LogFS file system"
2DESCRIPTION = "\
3LogFS is a Linux log-structured and scalable flash file system, intended \
4for use on large devices of flash memory. It is written by Jörn Engel and \
5in part sponsored by the CE Linux Forum. \
6LogFS is included in the mainline Linux kernel and was introduced in \
7version 2.6.34, released on May 16, 2010."
8HOMEPAGE = "https://github.com/prasad-joshi/logfsprogs"
9SECTION = "base"
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://fsck.c;md5=3859dc73da97909ff1d0125e88a27e02"
12DEPENDS = "zlib"
13
14SRC_URI = "git://github.com/prasad-joshi/logfsprogs.git"
15SRCREV = "45b72c81ce3c6fa17ca19bafc207ea93e76312f4"
16
17S = "${WORKDIR}/git"
18
19EXTRA_OEMAKE = "CC="${CC}" LD="${LD}" AR="${AR}""
20
21do_install () {
22 mkdir -p ${D}${bindir}
23 install -m 0755 ${S}/mklogfs ${D}${bindir}/mklogfs
24}
25
26BBCLASSEXTEND = "native nativesdk"