blob: 6957ea92bdaa473da5db9b91d916024360559800 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION = "The NTFS-3G driver is an open source, freely available NTFS driver for Linux with read and write support."
2HOMEPAGE = "http://www.ntfs-3g.org/"
3DEPENDS = "fuse libgcrypt"
4PROVIDES = "ntfsprogs ntfs-3g"
5LICENSE = "GPLv2 & LGPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
7 file://COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a"
8
9SRC_URI = "http://tuxera.com/opensource/ntfs-3g_ntfsprogs-${PV}.tgz"
10S = "${WORKDIR}/ntfs-3g_ntfsprogs-${PV}"
11
12SRC_URI[md5sum] = "2d6fb47ddf62b51733227126fe9227fe"
13SRC_URI[sha256sum] = "4b383f0074a3ab7683339d1f18222b107aaeb4983db119292c43c2b275cefb27"
14
15inherit autotools pkgconfig
16
17PACKAGECONFIG ??= ""
18PACKAGECONFIG[uuid] = "--with-uuid,--without-uuid,util-linux"
19
20# required or it calls ldconfig at install step
21EXTRA_OEMAKE = "LDCONFIG=echo"
22
23PACKAGES =+ "ntfs-3g ntfsprogs libntfs-3g"
24
25FILES_ntfs-3g = "${base_sbindir}/*.ntfs-3g ${bindir}/ntfs-3g* ${base_sbindir}/mount.ntfs"
26RDEPENDS_ntfs-3g += "fuse"
27RRECOMMENDS_ntfs-3g = "util-linux-mount"
28
29FILES_ntfsprogs = "${base_sbindir}/* ${bindir}/* ${sbindir}/*"
30FILES_libntfs-3g = "${libdir}/*${SOLIBS}"
31
32do_install_append() {
33 # Standard mount will execute the program /sbin/mount.TYPE
34 # when called. Add the symbolic to let mount could find ntfs.
35 ln -sf mount.ntfs-3g ${D}/${base_sbindir}/mount.ntfs
36}
37
38# Satisfy the -dev runtime dependency
39ALLOW_EMPTY_${PN} = "1"