blob: 253ea627b0d0d146b0a4dc162dee6490ae43077f [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Yet Another Flash File System"
2DESCRIPTION = "Tools for managing 'yaffs2' file systems."
3
4SECTION = "base"
5HOMEPAGE = "http://www.yaffs.net"
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://utils/mkyaffs2image.c;beginline=12;endline=14;md5=5f5464f9b3e981ca574e65b00e438561"
9
10PV = "0.0+git${SRCPV}"
11
12DEPENDS = "mtd-utils"
13
14# Source is the HEAD of master branch at the time of writing this recipe
15SRC_URI = "git://www.aleph1.co.uk/yaffs2;protocol=git;branch=master"
16SRCREV = "bc76682d93955cfb33051beb503ad9f8a5450578"
17S = "${WORKDIR}/git"
18
19CFLAGS_append = " -I.. -DCONFIG_YAFFS_UTIL -DCONFIG_YAFFS_DEFINES_TYPES"
20EXTRA_OEMAKE = "-e MAKEFLAGS="
21
22do_compile() {
23 cd utils && oe_runmake
24}
25
26INSTALL_FILES = "mkyaffsimage \
27 mkyaffs2image \
28 "
29do_install() {
30 install -d ${D}${sbindir}/
31 for i in ${INSTALL_FILES}; do
32 install -m 0755 utils/$i ${D}${sbindir}/
33 done
34}
35
36BBCLASSEXTEND = "native"