blob: 4ff95f97717cea9b64fd5fc4f20e7395530bf229 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Library functions to get attribute bits"
2DESCRIPTION = "The Data Management API (DMAPI/XDSM) allows implementation \
3 of hierarchical storage management software with no kernel \
4 modifications as well as high-performance dump programs \
5 without requiring "raw" access to the disk and knowledge \
6 of filesystem structures.This interface is implemented by \
7 the libdm library."
8
9HOMEPAGE = "http://oss.sgi.com/projects/xfs"
10SECTION = "base"
11LICENSE = "LGPLv2.1"
12LIC_FILES_CHKSUM = "file://doc/COPYING;md5=1678edfe8de9be9564d23761ae2fa794"
13DEPENDS = "xfsprogs"
14
15SRC_URI = "ftp://oss.sgi.com/projects/xfs/cmd_tars/dmapi-${PV}.tar.gz \
16 file://remove-install-as-user.patch \
17 file://dmapi_aarch64_configure_support.patch \
18 "
19SRC_URI[md5sum] = "cd825d4e141c16011367e0a0dd98c9c5"
20SRC_URI[sha256sum] = "b18e34f47374f6adf7c164993c26df36986a009b86aa004ef9444102653aea69"
21
22inherit autotools-brokensep
23
24PARALLEL_MAKE = ""
25EXTRA_OEMAKE += "LIBTOOL="${HOST_SYS}-libtool --tag=CC" V=1"
26
27do_install () {
28 export DIST_ROOT=${D}
29 install -d ${D}${libdir}
30 oe_runmake install install-dev PKG_DEVLIB_DIR=${libdir}
31}