blob: e053a6ef2992ad54d9498d2082aae70a9389ea30 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "XFS Filesystem Dump Utility"
2DESCRIPTION = "The xfsdump package contains xfsdump, xfsrestore and a \
3 number of other utilities for administering XFS filesystems.\
4 xfsdump examines files in a filesystem, determines which \
5 need to be backed up, and copies those files to a \
6 specified disk, tape or other storage medium."
7HOMEPAGE = "http://oss.sgi.com/projects/xfs"
8SECTION = "base"
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://doc/COPYING;md5=15c832894d10ddd00dfcf57bee490ecc"
11DEPENDS = "xfsprogs attr"
12
13SRC_URI = "ftp://oss.sgi.com/projects/xfs/cmd_tars/${BPN}-${PV}.tar.gz \
14 file://remove-install-as-user.patch \
15 "
16SRC_URI[md5sum] = "a8b1761be5feb363131e7b506639ad4c"
17SRC_URI[sha256sum] = "570eafd0721515bdd79cb0e295b701d49cdf81e71a0a0ff0df6d4c5cc1960943"
18
19inherit autotools-brokensep
20
21PARALLEL_MAKE = ""
22PACKAGECONFIG ??= ""
23PACKAGECONFIG[gettext] = "--enable-gettext=yes,--enable-gettext=no,gettext"
24
25EXTRA_OEMAKE += "'LIBTOOL=${HOST_SYS}-libtool' V=1"
26
27do_configure () {
28 export DEBUG="-DNDEBUG"
29 oe_runconf
30}
31
32do_install () {
33 export DIST_ROOT=${D}
34 oe_runmake install
35 oe_runmake install-dev
36}