blob: b26709e97cece1756ca639da55e3a92dbff78f6a [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION = "xorriso copies file objects from POSIX compliant filesystems \
2into Rock Ridge enhanced ISO 9660 filesystems and allows session-wise \
3manipulation of such filesystems"
4
5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
7
8SRC_URI = "http://www.gnu.org/software/${BPN}/${BPN}-${PV}.tar.gz"
9
10SRC_URI[md5sum] = "ec79fd2736b8da76e7a870e27cadf6fa"
11SRC_URI[sha256sum] = "0bd1e085015b28c24f57697d6def2fe84517967dc417554c0c3ccf1685ed0e56"
12
13PACKAGECONFIG ??= "acl attr zlib bzip2 readline"
14PACKAGECONFIG[acl] = "--enable-libacl,--disable-libacl,acl,"
15PACKAGECONFIG[attr] = "--enable-xattr,--disable-xattr,attr,"
16PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
17PACKAGECONFIG[bzip2] = "--enable-libbz2,--disable-libbz2,bzip2,"
18PACKAGECONFIG[readline] = "--enable-libreadline,--disable-libreadline,readline,"
19
20inherit autotools-brokensep pkgconfig distro_features_check
21
22do_configure_prepend () {
23 touch NEWS
24}
25
26RDEPENDS_${PN} = "tk"
27REQUIRED_DISTRO_FEATURES = "x11"
28
29BBCLASSEXTEND = "native"