blob: d3e08cadbb9ee5d971b52b6b56fdcf9cd0bda3eb [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "GTK+ applet for NetworkManager"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
4
5DEPENDS = "gtk+3 libnotify libsecret networkmanager dbus-glib gconf libgnome-keyring iso-codes nss"
6
7inherit gnomebase gsettings gtk-icon-cache gobject-introspection
8
9GNOME_COMPRESS_TYPE = "xz"
10
11SRC_URI[archive.md5sum] = "86b17e1bf1a37c649874883b587c6db6"
12SRC_URI[archive.sha256sum] = "b045ac3eaa68ccbbefe91510ad67b4002a7e09d1e5ce1c4bf9a67619bd2cf0eb"
13
14PACKAGECONFIG[bluetooth] = "--with-bluetooth,--without-bluetooth,gnome-bluetooth,gnome-bluetooth"
15PACKAGECONFIG[modemmanager] = "--with-modem-manager-1,--without-modem-manager-1,modemmanager"
16PACKAGECONFIG ??= ""
17
18do_configure_append() {
19 # Sigh... --enable-compile-warnings=no doesn't actually turn off -Werror
20 for i in $(find ${B} -name "Makefile") ; do
21 sed -i -e s:-Werror::g $i
22 done
23}
24
25RDEPENDS_${PN} =+ "networkmanager"
26
27FILES_${PN} += " \
28 ${datadir}/appdata \
29 ${datadir}/nm-applet/ \
30 ${datadir}/libnm-gtk/wifi.ui \
31"
32
33FILES_${PN} += "${libdir}/gnome-bluetooth/plugins/*.so"
34FILES_${PN}-dev += "${libdir}/gnome-bluetooth/plugins/libnma.la"
35FILES_${PN}-staticdev += "${libdir}/gnome-bluetooth/plugins/libnma.a"
36FILES_${PN}-dbg += "${libdir}/gnome-bluetooth/plugins/.debug/"