blob: 962a56cb9e81473ddb748eb70f3c5a045bd4cdf8 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "AbiWord is free word processing program similar to Microsoft(r) Word"
2HOMEPAGE = "http://www.abiword.org"
3SECTION = "x11/office"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=ecd3ac329fca77e2d0e412bec38e1c20"
6DEPENDS = "perl-native wv libglade libfribidi jpeg libpng \
7 librsvg libwmf-native gtkmathview asio gtk+ evolution-data-server \
8 ${@bb.utils.contains('BBFILE_COLLECTIONS', 'office-layer', 'redland rasqal', '', d)}"
9RDEPENDS_${PN} = "glibc-gconv-ibm850 glibc-gconv-cp1252 \
10 glibc-gconv-iso8859-15 glibc-gconv-iso8859-1"
11RCONFLICTS_${PN} = "${PN}-embedded"
12
13SRC_URI = " \
14 http://www.abisource.com/downloads/${BPN}/${PV}/source/${BP}.tar.gz \
15 file://0001-plugins-aiksaurus-Makefile.am-remove-uncomplete-opti.patch \
16"
17
18LIC_FILES_CHKSUM = "file://COPYING;md5=c5edcc3ccd864b19004d14e9c1c9a26a"
19
20SRC_URI[md5sum] = "f3f8052e7b4979a43b75775a381e6cb8"
21SRC_URI[sha256sum] = "e094f6fbf0afc5c5538b4894888e7c346f8ee8f49c9d24821dd696d0734865c6"
22
23#want 3.x from 3.x.y for the installation directory
24SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
25
26inherit autotools-brokensep pkgconfig
27
28PACKAGECONFIG ??= " \
29 collab-backend-xmpp collab-backend-tcp \
30 ${@bb.utils.contains('BBFILE_COLLECTIONS', 'office-layer', 'libical', '', d)} \
31"
32PACKAGECONFIG[libical] = "--with-libical,--without-libical,libical raptor2"
33PACKAGECONFIG[spell] = "--enable-spell,--disable-spell,enchant"
34PACKAGECONFIG[collab-backend-xmpp] = "--enable-collab-backend-xmpp,--disable-collab-backend-xmpp,libgsf libxml2 loudmouth"
35PACKAGECONFIG[collab-backend-tcp] = "--enable-collab-backend-tcp,--disable-collab-backend-tcp,libgsf libxml2"
36PACKAGECONFIG[collab-backend-service] = "--enable-collab-backend-service,--disable-collab-backend-service,libgsf libxml2 libsoup-2.4 gnutls"
37PACKAGECONFIG[collab-backend-telepathy] = "--enable-collab-backend-telepathy,--disable-collab-backend-telepathy,libgsf libxml2 telepathy-glib telepathy-mission-control"
38PACKAGECONFIG[collab-backend-sugar] = "--enable-collab-backend-sugar,--disable-collab-backend-sugar,libgsf libxml2 dbus-glib"
39
40EXTRA_OECONF = " --disable-static \
41 --enable-plugins \
42 --enable-clipart \
43 --enable-templates \
44 --without-gnomevfs \
45 --with-gtk2 \
46 --with-libwmf-config=${STAGING_DIR} \
47"
48
49do_compile() {
50 cd goffice-bits2
51 make goffice-paths.h
52 make libgoffice.la
53 cd ${B}
54 oe_runmake
55}
56
57PACKAGES += " ${PN}-clipart ${PN}-strings ${PN}-systemprofiles ${PN}-templates "
58
59FILES_${PN} += " \
60 ${libdir}/lib${PN}-*.so \
61 ${datadir}/mime-info \
62 ${datadir}/icons/* \
63 ${datadir}/${PN}-${SHRT_VER}/glade \
64 ${datadir}/${PN}-${SHRT_VER}/scripts \
65 ${datadir}/${PN}-${SHRT_VER}/system.profile-en \
66 ${datadir}/${PN}-${SHRT_VER}/system.profile-en_GB \
67 ${datadir}/${PN}-${SHRT_VER}/templates/normal.awt \
68 ${datadir}/${PN}-${SHRT_VER}/templates/normal.awt-en_GB \
69 ${datadir}/${PN}-${SHRT_VER}/templates/Employee-Directory.awt \
70 ${datadir}/${PN}-${SHRT_VER}/templates/Business-Report.awt \
71 ${datadir}/${PN}-${SHRT_VER}/templates/Fax-Coversheet.awt \
72 ${datadir}/${PN}-${SHRT_VER}/templates/Resume.awt \
73 ${datadir}/${PN}-${SHRT_VER}/templates/Two-Columns.awt \
74 ${datadir}/${PN}-${SHRT_VER}/templates/Memo.awt \
75 ${datadir}/${PN}-${SHRT_VER}/templates/Press-Release.awt \
76 ${datadir}/${PN}-${SHRT_VER}/certs \
77 ${datadir}/${PN}-${SHRT_VER}/ui \
78 ${datadir}/${PN}-${SHRT_VER}/xsl* \
79 ${datadir}/${PN}-${SHRT_VER}/mime-info \
80 ${datadir}/${PN}-${SHRT_VER}/Pr*.xml \
81"
82
83# don't steal /usr/lib/libabiword-3.0.so from ${PN}
84# in this case it's needed in ${PN}
85FILES_${PN}-dev = " \
86 ${includedir} \
87 ${libdir}/pkgconfig \
88 ${libdir}/${PN}*.la \
89 ${libdir}/lib${PN}*.la \
90 ${libdir}/${PN}-${SHRT_VER}/plugins/*.la \
91"
92FILES_${PN}-dbg += "${libdir}/${PN}-${SHRT_VER}/plugins/.debug"
93FILES_${PN}-doc += "${datadir}/${PN}-*/readme*"
94
95FILES_${PN}-strings += "${datadir}/${PN}-${SHRT_VER}/strings"
96FILES_${PN}-systemprofiles += "${datadir}/${PN}-${SHRT_VER}/system.profile*"
97FILES_${PN}-clipart += "${datadir}/${PN}-${SHRT_VER}/clipart"
98FILES_${PN}-strings += "${datadir}/${PN}-${SHRT_VER}/AbiWord/strings"
99FILES_${PN}-systemprofiles += "${datadir}/${PN}-${SHRT_VER}/AbiWord/system.profile*"
100FILES_${PN}-templates += "${datadir}/${PN}-${SHRT_VER}/templates"
101
102PACKAGES_DYNAMIC += "^${PN}-meta.* ^${PN}-plugin-.*"
103
104python populate_packages_prepend () {
105 abiword_libdir = d.expand('${libdir}/${PN}-${SHRT_VER}/plugins')
106 do_split_packages(d, abiword_libdir, '(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='')
107
108 metapkg = "abiword-meta"
109 d.setVar('ALLOW_EMPTY_' + metapkg, "1")
110 d.setVar('FILES_' + metapkg, "")
111 blacklist = [ 'abiword-plugins-dbg', 'abiword-plugins', 'abiword-plugins-doc', 'abiword-plugins-dev', 'abiword-plugins-locale' ]
112 metapkg_rdepends = []
113 packages = d.getVar('PACKAGES', 1).split()
114 for pkg in packages[1:]:
115 if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.count("-dev") and not pkg.count("-dbg") and not pkg.count("static") and not pkg.count("locale") and not pkg.count("abiword-doc"):
116 print "Modifying ", pkg
117 metapkg_rdepends.append(pkg)
118 d.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends))
119 d.setVar('DESCRIPTION_' + metapkg, 'abiword-plugin meta package')
120 packages.append(metapkg)
121 d.setVar('PACKAGES', ' '.join(packages))
122}
123
124FILES_${PN}-plugin-openxml += "${datadir}/${PN}-${SHRT_VER}/omml_xslt"