blob: 6e1997f77518b0dbf22a84487053bbf456e66791 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001LICENSE = "GPLv2"
2LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
3
4SECTION = "x11/gnome/libs"
5DEPENDS = "libxml2 gconf libsoup-2.4 gtk+3"
6
7PNBLACKLIST[libgweather3] ?= "CONFLICT: 876 files are conflicting with libgweather"
8# e.g. sysroots/qemux86-64/usr/share/libgweather/locations.dtd
9# sysroots/qemux86-64/usr/share/libgweather/Locations.zh_TW.xml
10
11BPN = "libgweather"
12
13inherit gnome
14SRC_URI[archive.md5sum] = "f1a96c6f19c9a0bc6b4e12acc9a8a85d"
15SRC_URI[archive.sha256sum] = "9041526fa0466b99dae5cf06c2cc70376f25531eec5d58b1e1378acfb302410c"
16
17do_configure_prepend() {
18 sed -i -e 's: doc : :g' ${S}/Makefile.am
19}
20
21FILES_${PN} += "${datadir}/gnome* \
22 ${datadir}/icons"
23
24PACKAGES =+ "${PN}-locationdata"
25FILES_${PN}-locationdata = "${datadir}/libgweather/*ocations*"
26
27
28