blob: 384841a8d3591f4f4d4155c059876e6cb705e2f0 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Helper lib for keyboard management"
2LICENSE = "LGPLv2"
3LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=6e29c688d912da12b66b73e32b03d812"
4
5DEPENDS = "xkbcomp gtk+ iso-codes libxi libxml2"
6
7GNOME_COMPRESS_TYPE = "xz"
8
9inherit gnomebase gettext gobject-introspection
10SRC_URI[archive.md5sum] = "290ea2a8abc40f78a3a16bdae6f02808"
11SRC_URI[archive.sha256sum] = "ebec3bc54b5652838502b96223152fb1cd8fcb14ace5cb02d718fc3276bbd404"
12
13EXTRA_OECONF = "--with-xkb-bin-base=${bindir}"
14
15do_configure_append() {
16 find ${B} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
17 find ${B} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
18}
19
20do_compile_append() {
21 sed -i -e s:${STAGING_DIR_TARGET}::g \
22 -e s:/${TARGET_SYS}::g \
23 libxklavier.pc
24}
25
26