blob: 919aa7bca0362525f6915837cbe3377b404905c0 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION="Gnome Office Library"
2
3LICENSE="GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=6dc33ff21e1ba1ac1a2a1069d361e29e"
5
6DEPENDS = "libxml-parser-perl-native glib-2.0 gtk+3 pango cairo libgsf libpcre libxml2 libart-lgpl librsvg intltool"
7
8inherit gnomebase pkgconfig perlnative gobject-introspection
9
10GNOME_COMPRESS_TYPE = "xz"
11
12SRC_URI += "file://0001-configure.ac-fix-paths-to-introspection-tools.patch"
13
14SRC_URI[archive.md5sum] = "90fd17c6fe205b779571e00d9b0b4727"
15SRC_URI[archive.sha256sum] = "5c38f4e81e874cc8e89481b080f77c47c72bfd6fe2526f4fc2ef87c17f96cad0"
16
17FILES_${PN}-dbg += "${libdir}/goffice/${PV}/plugins/*/.debug"
18
19RRECOMMENDS_${PN} = " \
20 goffice-plugin-plot-barcol \
21 goffice-plugin-plot-distrib \
22 goffice-plugin-plot-pie \
23 goffice-plugin-plot-radar \
24 goffice-plugin-plot-surface \
25 goffice-plugin-plot-xy \
26 goffice-plugin-reg-linear \
27 goffice-plugin-reg-logfit \
28 goffice-plugin-smoothing \
29"
30
31FILES_${PN} = "${bindir}/* ${sbindir}/* ${libexecdir}/* ${libdir}/lib*${SOLIBS} \
32 ${sysconfdir} ${sharedstatedir} ${localstatedir} \
33 ${base_bindir}/* ${base_sbindir}/* \
34 ${base_libdir}/*${SOLIBS} \
35 ${datadir}/${PN} \
36 ${datadir}/pixmaps ${datadir}/applications \
37 ${datadir}/idl ${datadir}/omf ${datadir}/sounds \
38 ${libdir}/bonobo/servers"
39
40FILES_${PN}-locale = "${libdir}/locale"
41
42PACKAGES_DYNAMIC += "^goffice-plugin-.*"
43
44python populate_packages_prepend () {
45 goffice_libdir = d.expand('${libdir}/goffice/${PV}/plugins/')
46
47 do_split_packages(d, goffice_libdir, '(.*)', 'goffice-plugin-%s', 'Goffice plugin for %s', allow_dirs=True)
48}
49